PathMATE Installation Guide

Version 1.8
June 29, 2011

Pathfinder Solutions
Wrentham, Massachusetts USA
www.pathfindermda.com
888-662-7284

©2011 by Pathfinder Solutions

Deleted: January 10

Table Of Contents
Preface......................................................................................................... 1
Download PathMATE .................................................................................... 3
Install and Prepare UML Editor..................................................................... 4
Install UML Editor ......................................................................................4
Prepare Rational Rose................................................................................4
Install PathMATE.......................................................................................... 6
Install PathMATE .......................................................................................6
Obtain a License .......................................................................................6
Finding the License Host Name and Id .....................................................7
Add PathMATE to Rational Rose...................................................................9
Upgrade PathMATE..................................................................................... 11
Uninstall the Previous Version of PathMATE ................................................11
Install PathMATE .....................................................................................11
Add PathMATE to Rational Rose.................................................................12
Verifying Your Installation ......................................................................... 14
Instantiate the SimpleOven Example .........................................................14
Transform SimpleOven to Code.................................................................14
Build and Execute SimpleOven ..................................................................14
Troubleshooting Guide ............................................................................... 16
Frequently Asked Questions......................................................................16
Support .................................................................................................17
Install Optional PathMATE Transformation Maps ....................................... 18
Install the C Map.....................................................................................18
Install the Java Map ................................................................................18
A.

Install a Node Locked License ............................................................. 20

B.

Install a Floating License .................................................................... 21

C.

Connecting PathMATE Clients to the License Server ............................ 24

D.

Administrating the License Server....................................................... 26

ii

E.

Verify Installation of License............................................................... 28

F.

Glossary .............................................................................................. 30

iii

Preface
Audience
The PathMATE Installation Guide is written for engineers, system
administrators, and others who want to install and get started with
PathMATE.

Software Requirements
PathMATE requires Windows XP Professional, Windows 7, 32 bit or 64
bit, and a supported UML editor: Rational Software Modeler (RSM)
v7.0 or higher, Rational Software Architect (RSA) v7.0 or higher, or
Rational Rhapsody v7.0 or higher.

Conventions
The PathMATE Installation Guide uses these conventions:
• Bold is for clickable buttons and menu selections.
• Italics are for path and file names, and other text that needs
special emphasis.
• Blue italics in the electronic version of the guide are for active
links. Click the link to go to the indicated heading.
• A NOTE contains important information, or a tip that saves you
time.
• All path names assume you have installed the Pathfinder software
in the default directory, C:\pathmate\...

Related Documents
The PathMATE Quick Start Guide contains more information about how
to become familiar with PathMATE. It explains how to develop a simple
model, and how to transform the model with PathMATE. To open the
Quick Start Guide:
• For Rational Software Modeler (RSM) or Rational Software
Architect (RSA) see C:\pathmate\doc\QuickStartGuide_RSM.pdf
• For Rational Rhapsody see
C:\pathmate\doc\QuickStartGuide_Rhapsody.pdf
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Contents of this Guide
Download the latest version of PathMATE from the Pathfinder website.
Download PathMATE on page 3 explains how. Then:
• If you are a new user, turn to Install and Prepare UML Editor on
page 4. If you have already installed PathMATE on your machine
and you need to upgrade to the latest version, turn to Upgrade
PathMATE on page 11.
• If you need to install or upgrade a PathMATE transformation map,
turn to Install Optional PathMATE Transformation Maps on
page 18.
• If you have difficulty with any of the operations explained here,
turn to the Troubleshooting Guide on page 14.
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Download PathMATE
PathMATE is a powerful set of software development tools that you
can use to create complex embedded systems from UML models.
The PathMATE Installation Guide explains how to install PathMATE
on your computer. This section explains how to download
PathMATE from www.pathfindermda.com.
1.

Point your browser to http://www.pathfindermda.com. The
Pathfinder Solutions home page opens.

2.

Click PathTECH Login in the horizontal menu bar.

3.

Log into PathTECH with User ID demo. Please contact your
sales representative to obtain your password.

Figure 1-1. PathTECH Login
4.

Follow the brief instructions in the PathTECH Support Area.
Download the install files for the PathMATE Environment and
any optional Transformation Maps.

Whether you need to install PathMATE for the first time, or upgrade
your PathMATE installation, install the base PathMATE toolset
before you install any other PathMATE components.
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Install and Prepare UML Editor
Install UML Editor
Obtain the install programs and a license file for the supported UML
editor that you will be using to create your models. Install the editor
using the instructions provided by the vendor.

Prepare Rational Rose
If you are not using Rational Rose to create models, skip to the next
step.
The PathMATE toolset transforms models developed in Rational Rose
into executable code. The models that you work with in Rational Rose
require that you define the current directory (CURDIR) symbol in Rose.
To define the symbol:
1.

Start Rational Rose.

2.

Click File > Edit Path Map… in the top menu bar.
Virtual Path Map opens.

Figure 1: Virtual Path Map
3.

Enter CURDIR in the Symbol field.

4.

Enter & in the Actual Path field and click Add.
The new mapping appears under Virtual Symbol to Actual Path
Mapping.
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Figure 2: Virtual Path Map
5.

Close the Virtual Path Map dialog box.
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Install PathMATE
The installation procedure for PathMATE involves these steps:
1.

Install PathMATE.

2.

Obtain a PathMATE license.

3.

For Rational Rose users, add PathMATE to Rational Rose.

Install PathMATE
To install PathMATE:
1.

Locate pathmate-x-xx-xxx.exe in the download directory, and
double-click the filename.
The installation wizard opens (Figure 3: PathMATE Installation
Wizard).

Figure 3: PathMATE Installation Wizard
2.

Follow the prompts in the installation wizard to install the
program.
At the end of the installation process, a dialog box prompts you
to restart your computer for the configuration changes made to
PathMATE to take effect.

3.

Click Yes to restart your computer.

Obtain a License
To obtain a PathMATE license, perform the steps below:
1.

Determine the host name and host id of the computer where
the license will be installed.
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For a node locked license, perform the steps below on the
computer where you will use PathMATE.
For a floating license, perform the steps below on the computer
that will host the PathMATE license server. The license server must
run the Windows operating system and must be accessible though
the network by all PathMATE users.
Finding the License Host Name and Id
Method 1: From Rational Software Developer or Eclipse
1.

If you are using Rational Software Developer, start it from the
Windows desktop.
If you are using Rose, select Start > Programs > Pathfinder
Solutions > Eclipse in the Windows desktop.

4.

From the main menu select Windows > Preferences. The
Preferences Dialog appears.

Figure 2-3. Preferences Dialog – General
5.

Select PathMATE > Licensing from the tree on the left side of
the dialog.
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License Host
Name and Id

Figure 2-3. Preferences Dialog – PathMATE - Licensing
6.

The license host name and id are located in the License
Information section near the top right of the dialog. Select the
host name and host id strings, copy them and paste them into
an email message. Email the license host information to
plms@pathfindermda.com.

7.

Close Rational Software Developer or Eclipse.

8.

When you receive your license from Pathfinder by return email, save node locked .lic file in C:\pathmate\lic. If you are
using a floating license, see Install a Floating License on
page 20 and Connecting PathMATE Clients to the License Server
on 24.

Method 2: Using the Command Line
1.

From the Windows desktop select Start > Run. The Run
dialog will appear.

2.

Enter cmd in the Open field. Click OK. The Command Prompt
opens.

3.

Enter cd <pathmate_root>\lic to change to the lic subdirectory
of the PathMATE install tree where <pathmate_root> is the
location where PathMATE is installed. The default location is
c:\pathmate.
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Host Id
Host Name

Figure 4: Finding the License Host Id and Name using Command
Prompt
4.

Enter rlmhostid to get the license host id.

5.

Enter rlmhostid host to get the license host name.

6.

E-mail the license host id and license host name to
plms@pathfindermda.com.

7.

When you receive your license from Pathfinder by return email, save node locked .lic file in C:\pathmate\lic. If you are
using a floating license, see Install a Floating License on
page 20 and Connecting PathMATE Clients to the License Server
on 24.

Add PathMATE to Rational Rose
If you are not using Rational Rose, skip this step.
To complete the installation for Rational Rose, and to verify that
PathMATE is installed correctly:
1.

Launch Rational Rose.

2.

Select Add-Ins > Add-In Manager in the top menu bar.
The Rational Rose Add-In Manager opens (Rational Rose Add-In
Manager).
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Figure 2-7. Rational Rose Add-In Manager
3.

Check the box next to PathMATE.

4.

Click OK to close the Add-In Manager.
Select Tools in the top menu bar and check the list of items in
the drop-down menu.

5.

If PathMATE Generate and PathMATE Options appear in the
drop-down menu, PathMATE is ready to use with Rational Rose.
If the installation was unsuccessful, please contact Pathfinder
Solutions.
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Upgrade PathMATE
The upgrade procedure for PathMATE involves three steps:
1.

Uninstall the previous version of PathMATE.

2.

Install PathMATE.

3.

For Rational Rose users, add PathMATE to Rational Rose.

Uninstall the Previous Version of PathMATE
To uninstall a previous version of PathMATE:
1.

Select Start > Settings > Control Panel in the Windows desktop
to open the control panel.

2.

Double-click Add or Remove Programs.

3.

Select PathMATE and remove it.
Check the install directory and verify that all files except the .lic
file are removed. The uninstaller does not remove files
generated from any samples you may have built. You must use
Windows Explorer to remove these files from C:\pathmate.
Use the Windows Add or Remove Programs utility to uninstall
previous versions of PathMATE Transformation Map for C and
PathMATE Transformation Map for Java. These are optional
components and may not be installed on your system.

Install PathMATE
To install PathMATE:
1.

Locate pathmate-x-xx-xxx.exe in the download directory, and
double-click the filename.
The installation wizard opens (Figure 3: PathMATE Installation
Wizard).
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Figure 3-1. PathMATE Installation Wizard
2.

Follow the prompts in the installation wizard to install the
program.
At the end of the installation process, a dialog box prompts you
to restart your computer for the configuration changes made to
PathMATE to take effect.

3.

Click Yes to restart your computer.

Add PathMATE to Rational Rose
If you are not using Rational Rose, skip this step.
To complete the installation, and to verify that PathMATE is installed
correctly:
1.

Launch Rational Rose.

2.

Select Add-Ins > Add-In Manager in the top menu bar.
The Rational Rose Add-In Manager opens (Rational Rose Add-In
Manager).

12

Figure 3-2. Rational Rose Add-In Manager
3.
4.
5.

Check the box next to PathMATE.
Click OK to close the Add-In Manager.
Select Tools in the top menu bar and check the list of items in
the drop-down menu.
If PathMATE Generate and PathMATE Options appear in the
drop-down menu, PathMATE is ready to use with Rational Rose.
If the installation was unsuccessful, please contact Pathfinder
Solutions (see the Troubleshooting Guide on page 14).
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Verifying Your Installation
Follow these steps to ensure your installation was set up correctly:
1.

Instantiate the SimpleOven example.

2.

Transform SimpleOven to code.

3.

Build and execute SimpleOven.

Before starting ensure you are in the Eclipse Resource perspective.
Use Window > Open Perspective.

Instantiate the SimpleOven Example
1.

In Eclipse, click File > New > Example.

2.

In the wizard filter field type SimpleOven
For RSM/RSA: select the SimpleOven example system under
the PathMATE folder and click Next.

3.

For Rhapsody: select the SimpleOven example system under
the PathMATE for Rhapsody folder and click Next.
4. In the ProjectName field enter SO-verify and click Finish.
3.

5.

See the new project SO-verify in the Eclipse Project Explorer.

Transform SimpleOven to Code
1.

In the Eclipse Project Explorer select the project SO-verify and
click File > New > Other.

2.

In the wizard filter field type PathMATE

3.

Select the PathMATE Project under the PathMATE folder and
click Next.

For RSM/RSA: Select the SimpleOven SYSTEM MODEL.emx
model file in the SO-verify project and click Next.
4. For Rhapsody: Select the SimpleOven.rpy model file in the
SO-verify project and click Next.
4.

5.

See the new project on the Eclipse Project Explorer.

Build and Execute SimpleOven
1.

The PathMATE transformation project editor is open in the
center Eclipse pane. Select the deployment Single Process
C++, and click Edit on the right side of the Transformation field
(on the right side of the pane).

2.

In the Transformation Maps window ensure the PathMATE C++
and Build file generation Maps appear in order. If not, use the
Add and/or Up/Down buttons to adjust.

3.

In the Project Explorer expand the SO-verify project and
browse to the cpp folder. Open properties.txt – this is the
markings file.
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4.

Specify the version of Visual Studio you have installed by
uncommenting the line specifying the TargetIDE property
(around line 7) and changing its value as appropriate. E.g. set
this to VS8 for Visual Studio 2005, or to VS9 for Visual Studio
2008:

System,SimpleOven,TargetIDE,VS8
5.

Save the changes to properties.txt. In the PathMATE pane click
Transform. Browse to the cpp folder, and see the generated
code in the cpp/gc folder, and go into the cpp/MAIN folder and
open the main VS project solution file, MAIN.sln.

Now build and execute the SimpleOven system in Visual Studio.
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Troubleshooting Guide
If the FAQ below does not address your problem, please call Customer
Service for help.

Frequently Asked Questions
Q: What should I do if I receive a "connection refused" error message
when attempting to connect to the license server or access the license
administration web page?
A: If there is a firewall hardware device on the network or Windows
firewall software running on the license server, the ports used by the
license server must be open on all firewalls. The required ports and
how to set them follow:
Required Port

How to Configure

Reprise License Manager

The last parameter of the HOST line in
the PathMATE license file:
HOST <host_name> <host_id> <port>

Pathfinder ISV Server

The last parameter of the ISV line in the
license file:
ISV pathfinder pathfinder <port>
If no port is specified, the license
software chooses a free port. If the
license server needs to be accessed
across a firewall, select a port and
specify on the ISV line in the PathMATE
license file.

Reprise Web Server Port

The default port is 9000. To change the
port, open the properties for the service
that starts the license server. (See the
Install a Floating License section for
further instructions on how to access the
license server Windows service.) Add the
–ws <port> option to the command line
for the service.

Q: What should I do if one of the ports required by the license server
is in use?
A: Consult the table above showing the ports required by the license
server and how to configure them. Change either the license file or
the parameters to the license server command. Start the license
server.
Q: What should I do if I receive a message that tells me my PathMATE
license has expired, or I have some other problem with my PathMATE
license?
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A: Contact Pathfinder Solutions Administration at 888-662-7284 x102,
or write to admin@pathfindermda.com. To initiate a request for a new
license, follow the instructions in Obtain a License on page 6.
Q: What should I do if PathMATE Generate doesn’t appear in the
Rational Rose Tools menu?
A: You may have to use the Rose Add-In Manager to add PathMATE’s
functions to the tools menu. Select Add-Ins > Add-In Manager... in
Rose’s top menu bar, then select the checkbox for PathMATE in the
Add-In Manager.
Q: What should I do if Rational Rose or Rational Software Modeler says
that my license is not current, or I have some other problem with my
UML editor license?
A: You should contact your IBM representative, explain the
circumstances, and ask for an evaluation license.

Support
If you have technical trouble with the installation process, or any other
technical questions about PathMATE, please contact Pathfinder
Solutions Support at 888-662-7284 x103 or
support@pathfindermda.com. Your inquiry will receive a prompt
response.
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Install Optional PathMATE
Transformation Maps
This section explains how to install the optional C Map and Java Map.
They do not come bundled with the base PathMATE product, so you
can update them separately. The procedures assume that you have
not installed a previous version of the C Map or the Java Map. If you
have installed a previous version and you need to upgrade, you must
uninstall the previous version before you execute the steps in the
installation procedure.

Install the C Map
To install the C Transformation Map:
1.

Locate pathmate_c-x-xx-xxx.exe in the download directory on
your local drive, and double-click the filename.
The installation wizard opens (Figure 3: PathMATE Installation
Wizard).

Figure 6-1. PathMATE Installation Wizard
2.

Follow the prompts in the installation wizard to install the
program.

3.

When the installation procedure is complete, check
c:\pathmate\design\c\... to verify that the C Map is installed
correctly.

Install the Java Map
To install the Java Transformation Map:
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1.

Locate pathmate_java-x-xx-xxx.exe in the download directory
on your local drive, and double-click the filename.
The installation wizard opens (Figure 3: PathMATE Installation
Wizard).

Figure 6-2. PathMATE Installation Wizard
2.

Follow the prompts in the installation wizard to install the
program.

3.

When the installation procedure is complete, check
c:\pathmate\design\java\... to verify that the Java Map is
installed correctly.
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A. Install a Node Locked License
Follow these steps to install a node locked license:
1.

Exit Rational Software Developer and/or Eclipse if they are
open.

2.

Log in using an account with Administrator privileges.

3.

Copy the license file to <pathmate_root>\lic.

4.

Restart Rational Software Developr or Eclipse.
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B. Install a Floating License
Follow these steps to install a floating license on the license server:
1.

Log into the license server using an account with Administrator
privileges.

2.

Copy the license file to <pathmate_root>\lic.

3.

Install a service that starts the PathMATE license server. Open
a command prompt and enter:
cd c:\pathmate\lic
rlm -install_service -service_name "PathMATE License Manager"
-dlog <pathmate_root>\lic\license_manager.log -c
<pathmate_root>\lic
NOTE: Always use fully qualified paths for the -dlog and –c
options. The license manager will not start properly if relative
paths are used.

6. From the Windows desktop, select Start > Control Panel.
The Control Panel opens.
7. Open Administrative Tools > Services.
8. Select the Standard tab. See Figure 5: Standard Services.

Figure 5: Standard Services

Double click the PathMATE License Manager service. The
service properties dialog appears. See Figure 6: License
Manager Service Properties.
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Figure 6: License Manager Service Properties

9. Click Start to start the license server. A progress dialog will
appear briefly while the license server starts. The PathMATE
License Manager service will start the license manager
automatically when the license server restarts. A manual start
is only required immediately following installation.
10. Click OK to dismiss the service properties dialog.
11. Verify that the license server is running properly by entering
the following commands in a command prompt:
cd c:\pathmate\lic
rlmstat
Figure 7: Verifying License Server Status shows an example of
a good status. If the license server is not running, rlmstat will
print an error message "Error connecting to "rlm" server"
followed by details of the error condition.
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Figure 7: Verifying License Server Status

12. Open the license server log file located in
<pathmate_root>\lic\license_manager.log. Inspect the license
server error log for problems encountered during startup.
Each PathMATE installation accessing this license server must be
configured with the license server name and port number. See
Connecting PathMATE Clients to the License Server for instructions
on how to configure PathMATE clients.
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C. Connecting PathMATE Clients to
the License Server
Follow these steps on each computer where PathMATE will be used:
1.

Log in using an account with Administrator privileges.

2.

If you are using Rational Software Developer, start it from the
Windows desktop.
If you are using Rose, select Start > Programs > Pathfinder
Solutions > Eclipse in the Windows desktop.

3.

From the main menu select Windows > Preferences. The
Preferences Dialog appears.

Figure 2-3. Preferences Dialog – General
4.

Select PathMATE > Licensing from the tree on the left side of
the dialog.
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License
Settings

Figure 2-3. Preferences Dialog – PathMATE – Licensing
5.

Open the PathMATE license file and find the HOST line. The
HOST line:
HOST host_name host_id port

6.

In the License type field, select Floating License.

7.

In the License Server Host field, enter the host_name specified
on the HOST line of the license file.

8.

In the License Server Port, enter the port specified on the HOST
line of the license server.

9.

Click Ok.

10.

Exit Rational Software Developer or Eclipse.

11.

Follow the instructions in the Verify Installation of License
section on page 26 to ensure that PathMATE checks out a
license properly.
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D. Administrating the License
Server
Follow these steps to determine if the PathMATE license server is
operating properly or to change how the license server is configured:
1.

Open a web browser. Enter the url
http://<licenseserverhost>:9000. The Reprise License Server
Administration page appears.

Figure 8: License Manager Administration Page
2.

Click on the Status link on the left side of the browser window.
The status of the license server displays appears.
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License
Server
Status

Pathfinder
ISV Server
Commands

Figure 9: License Server Status Web Page
3.

The Status page shows the status of the rlm license manager
server and the pathfinder ISV server. Click the pathfinder
button in the ISV table to perform one of the following:
Command Name

Command Description

Server Status

Show pathfinder ISV server status.
Show number of available licenses.

License Usage

Show which licenses are checked out
and by whom.

Show DebugLog

Display the contents of the license
server log file.

REREAD/RESTART

If the Pathfinder ISV server is not
running, start it. If it is running already,
read a new version of the license file.

SHUTDOWN

Shutdown the Pathfinder ISV server.
This does not shut down the main rlm
server process.
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E. Verify Installation of License
Follow these steps after changing the license configuration on each
computer where PathMATE will be used:
1.

If you are using Rational Software Developer, start it from the
Windows desktop.
If you are using Rose, select Start > Programs > Pathfinder
Solutions > Eclipse in the Windows desktop.

2.

From the main menu, select Windows > Open Perspective >
Other. The Open Perspective dialog appears.

3.

Select the Modeling perspective. Click Ok.

4.

From the main menu, select Windows > Show View >
Action Language. Opening the PathMATE action language
view will check out a PathMATE engine license. If an error
dialog appeared when opening the action language view, the
license was not checked out properly. Check the license server
log to make sure it started properly. If the license server
started ok, verify that it is using the correct license file.

5.

From the main menu select Windows > Preferences. The
Preferences Dialog appears.

6.

Select PathMATE > Licensing from the tree on the left side of
the dialog.

7.

If an engine license and its expiration date appear under the
host name and host id, the license is properly installeds. See
Figure 10: Checking the License Expiration Date.
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License
Expiration
Date

Figure 10: Checking the License Expiration Date
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F. Glossary
C Map

Templates and run-time mechanisms used with PathMATE to generate C
code.

CURDIR

Current directory

Floating license

A license installed on a license server. Valid for a specified number of
seats.

Java Map

Templates and run-time mechanisms used with PathMATE to generate
Java code.

Node locked license

A license valid only on the machine where it is installed.

PathMATE

Pathfinder Model Automation and Transformation Environment

PathTECH

The portal for downloading the PathMATE installer and related files,
accessed via login at the top of the www.pathfindermda.com page.
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